PHP 7.2.9 Released

Fonctionnalités obsolètes en PHP 5.3.x

PHP 5.3.0 introduit deux nouveaux niveaux d'erreur : E_DEPRECATED et E_USER_DEPRECATED. Le niveau d'erreur E_DEPRECATED sert à indiquer qu'une fonctionnalité est obsolète, et E_USER_DEPRECATED sert à la même chose pour les fonctions utilisateur, tout comme E_USER_ERROR et E_USER_WARNING .

Voici une liste des directives INI obsolètes : si l'une d'entre elle est activée, elle va émettre une alerte d'obsolescence (E_DEPRECATED) au démarrage.

Fonctions obsolètes :

Fonctionnalités obsolètes :

  • Assigner la valeur de retour de l'opérateur new par référence est obsolète.
  • Le passage par référence à l'appel est maintenant obsolète.
add a note add a note

User Contributed Notes

There are no user contributed notes for this page.
To Top