PHP Australia Conference 2015

Fonctionnalités devenues obsolètes en PHP 5.5.x

Obsolescence de l'extension ext/mysql

L'extension MySQL originale est maintenant obsolète, et génèrera des alertes de niveau E_DEPRECATED lors de la connexion à une base de données. A la place, utilisez l'extension MySQLi ou l'extension PDO_MySQL.

Modificateur /e de la fonction preg_replace()

Le modificateur /e de la fonction preg_replace() est maintenant obsolète. A la place, utilisez la fonction preg_replace_callback().

Obsolescences dans l'extension intl

La méthode IntlDateFormatter::setTimeZoneID() et la fonction datefmt_set_timezone_id() deviennent obsolètes. Utilisez à la place, respectivement, la méthode IntlDateFormatter::setTimeZone() et la fonction datefmt_set_timezone().

Obsolescences dans l'extension mcrypt

Les fonctions suivantes sont désormais obsolètes :

add a note add a note

User Contributed Notes

There are no user contributed notes for this page.
To Top