PHP 5.5.15 is released

Pré-requis

L'extension SDO requiert PHP 5.1.0 ou supérieur. Elle nécessite également la bibliothèque libxml2. Normalement, libxml2 devrait être déjà installée mais si ce n'est pas le cas, vous pouvez la télécharger depuis » http://www.xmlsoft.org/.

add a note add a note

User Contributed Notes 2 notes

up
1
jerrywilborn at gmail dot com
3 years ago
The extension does not compile against PHP 5.3.  Additionally, it uses SoapServer::setObject() which has only been available since PHP 5.2.
up
0
pallsopp at gmail dot com
1 year ago
That is not strictly true!

Make these changes and it will compile just fine.

If using with PHP >= 5.3.0, you need to make the following source code
changes:

remove all "static" except "static char rcs_id[] ..." from sdo.cpp.

Add #include <stdio.h> to commonj/sdo/SDODataConverter.cpp

/usr/local/lib/php/SCA/SCA_CommentReader.php
  Line 381: $targetLine = preg_replace("{[ \t]+}", " ", $targetLine);
  Line 385: if (strpos($word,$bindingAnnotation) === 0) {
  Line 592: $targetLine = preg_replace("{[ \t]+}", " ", $targetLine);

/usr/local/lib/php/SCA/SCA_AnnotationRules.php
  Line 222:  $line         = preg_replace("{[ \t]+}", " ", $line);

I did exactly that on a 64bit CentOS box and it works fine.
To Top