PHP 5.6.0 released

Installazione

Nei sistemi UNIX, eseguire configure con le opzioni --enable-xslt --with-xslt-sablot . La libreria Sablotron deve essere installata in una posizione accessibile al compilatore.

Accertarsi di utilizzare per il PHP le medesime librerie utilizzate per Sablotron. I parametri di configurazione sono: --with-expat-dir=DIR --with-iconv-dir=DIR . Quando si chiede supporto, ricordarsi di citare sempre queste impostazioni, e dove sono installate altre versioni di queste librerie nel sistema. Ovviemente fornire i numeri di versione.

Attenzione

Accertarsi che la libreria Sablotron sia compilata con -lstdc++ altrimenti potrebbe fallire il processo di configurazione oppure il PHP non essere in grado di caricare la libreria.

Nota: Supporto per JavaScript E-XSLT
Se si compila Sablotron con il supporto JavaScript, occorre indicare il parametro: --with-sablot-js=DIR .

Nota: Nota per gli utenti Win32

Perché questa estensione possa funzionare, delle DLL devono essere disponibili nel PATH di sistema di Windows. Vedere la FAQ intitolata "Come aggiungere la cartella di PHP al PATH in Windows" per informazioni su come farlo. Anche se copiare i file DLL dalla cartella di PHP alla cartella di sistema di Windows funziona (poiché la cartella di sistema è di default nel PATH di sistema), non è raccomandato. Questa estensione richiede che i seguenti file siano nel PATH: sablot.dll, expat.dll, e iconv.dll

Per PHP <= 4.2.0, il file iconv.dll non è richiesto.

add a note add a note

User Contributed Notes

There are no user contributed notes for this page.
To Top