PHP Australia Conference 2015

要件

PDO データベースドライバを書くために必要な条件は、以下のとおりです。

  1. 対象となるデータベースの稼働環境・例・デモなど、ベンダの仕様どおりに 動作するもの。

  2. 開発環境

    1. その他の Unix: ベンダが提供する標準開発ツールに加え、 GNU の開発ツールセット

    2. Linux: 標準的な開発ツール、gcc・ld・make・autoconf・automake など…。ディストリビューションに応じたバージョンのもの

    3. Win32: Visual Studio コンパイラ

  3. PHP バージョン 5.0.3 以降および PEAR バージョン 1.3.5 以降の環境

  4. PDO の動作環境 ('sudo pecl install PDO' を使用してインストール できます)。ここには PDO の型定義や関数定義にアクセスするための ヘッダが含まれます

  5. C 言語についての十分な知識

  6. PHP の拡張モジュールを書く方法についての十分な知識。 George SchlossnagleAdvanced PHP Programming (Developer's Library 発行、第 21 章および第 22 章) がお勧めです。

  7. 最後に、PHP の心臓部である Zend API に (特にメモリ管理の面で) 習熟していること。

add a note add a note

User Contributed Notes

There are no user contributed notes for this page.
To Top