ScotlandPHP

Requisitos de instalação

O PHP 5.5+ requer ao menos Windows 2008/Vista, ou 2008r2, 2012, 2012r2, 2016 ou 7, 8, 8.1, 10. 32-Bit ou 64-bit (aka X86 or X64; PHP não roda no Windows RT/WOA/ARM).

O PHP requer o Visual C runtime (CRT). Muitas aplicações também tem esse requisito, de forma que ele já deve estar instalado.

PHP 5.4, 5.5, e 5.6 requerem VC CRT 11 (Visual Studio 2012). Veja: » https://www.microsoft.com/en-us/download/details.aspx?id=30679

PHP 7.0+ requer VC CRT 14 (Visual Studio 2015). Ver: » https://www.microsoft.com/en-us/download/details.aspx?id=48145

Você PRECISA instalar o CRT x86 para compilar o PHP em x86 builds CRT x64 para compilações PHP x64.

Se o CRT já está instalado, o instalador irá avisar que não fez nenhuma alteração.

O instalador CRT suporta as opções de linha de comando /quiet e /norestart, de forma que você pode automatizar o passo de instalação.

DLLs do CRT VC11 podem ser copiadas da sua máquina local para uma máquina remota (uma instalação "Copy Deployment") em vez de rodar o instalador na máquina remota (como o caso de uma máquina onde tenha acesso restrito. Veja: http://www.sitepoint.com/install-php53-windows/

O CRT VC14 não suporta uma instalação installation "Copy Deployment". CRT VC14 tem muitas DLLs a mais (a maioria com nomes iniciando com api-*). Se você conseguir achar todas e copiá-las isso pode funcionar (tente uma ferramenta como Resource Hacker para obter uma lista de DLLs a copiar).

add a note add a note

User Contributed Notes

There are no user contributed notes for this page.
To Top