CakeFest 2017 NYC, the Official CakePHP Conference

Anforderungen

Mit der GD-Bibliothek (verfügbar unter » http://www.libgd.org/) können Sie auch Grafiken erzeugen und manipulieren.

Die mittels dieser Funktionen veränderbaren Grafik-Formate hängen davon ab, welche Version von GD Sie installieren und welche zusätzlichen Bibliotheken GD benötigt, um mit diesen Formaten umgehen zu können. GIF wird ab gd-2.0.28 unterstützt.

Hinweis: Ab PHP 5.0 wird libgd-2.0.4 oder höher benötigt. Ab PHP 5.5 wird libgd-2.1.0 oder höher benötigt. Alternativ kann die gebündelte GD-Bibliothek, die mit PHP ab 4.3 ausgeliefert wird, verwendet werden.

Sie können GD erweitern, um mehr Grafikformate zu verwenden.

Unterstützte Grafikformate
Grafikformat Download der benötigten Bibliothek Anmerkungen
gif   Wird nur von GD-Versionen neuer als gd-2.0.28 unterstützt. Schreiben von GIF wird ab PHP 5.0.1 unterstützt.
jpeg » http://www.ijg.org/ Wenn Sie die jpeg-Bibliothek übersetzen (vor dem Übersetzen von PHP), müssen Sie die Option --enable-shared im configure-Schritt benutzen. Wenn Sie dies nicht tun, werden Sie den Fehler libjpeg.(a|so) not found beim configure-Schritt der PHP-Übersetzung erhalten.
png » http://www.libpng.org/pub/png/libpng.html Nur von GD-Versionen neuer als gd-1.6 unterstützt.
xpm » ftp://metalab.unc.edu/pub/Linux/libs/X/!INDEX.html

Sie können GD erweitern, um unterschiedliche Schriften zu verwenden. Die folgenden Schriftbibliotheken werden unterstützt.

Unterstützte Schriftbibliotheken
Schriftbibliothek Download Anmerkungen
FreeType 1.x » http://www.freetype.org/ Die Unterstützung von FreeType 1.x wurde ab PHP 5.3.0 entfernt.
FreeType 2 » http://www.freetype.org/  
T1lib » ftp://sunsite.unc.edu/pub/Linux/libs/graphics/) Unterstützung für Type 1-Schriften. (Entfernt ab PHP 7.0.0).

add a note add a note

User Contributed Notes

There are no user contributed notes for this page.
To Top