SunshinePHP Developer Conference 2015

Direct-IO-Funktionen

Inhaltsverzeichnis

  • dio_close — Schließt eine Datei
  • dio_fcntl — Modifiziert einen Dateideskriptor
  • dio_open — Öffnet eine Datei mit den angegebenen Rechten
  • dio_read — Liest von einem Dateideskriptor
  • dio_seek — Setzt den Dateizeiger
  • dio_stat — Liefert Statusinformationen über einen Dateideskriptor
  • dio_tcsetattr — Sets terminal attributes and baud rate for a serial port
  • dio_truncate — Schneidet eine Datei ab
  • dio_write — Schreibt Daten in eine Datei
add a note add a note

User Contributed Notes 3 notes

up
0
php dot 5 dot gavinostlund at spamgourmet dot com
6 years ago
You can manually build the dio extension for your version of PHP, or install an older version of PHP that still bundled dio.  It's not that hard to build it yourself, just a bit of a process, and it helps if you're on linux, and have a build environment... which I would assume you have if you are doing some kind of development that requires direct device I/O...  Just get the dio source from the cvs repo, compile it, and then add the extension to your php configuration...
up
0
tom at bitworks dot de
6 years ago
to use mandatory locking on a linux system, the filesystem has to be well prepared.

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>               <dump>  <pass>
/dev/hda1       /               ext3    errors=remount-ro,mand  0       1
/dev/hda2       none            swap    sw                      0       0
proc            /proc           proc    defaults                0       0
/dev/fd0        /floppy         auto    user,noauto             0       0
/dev/cdrom      /cdrom          iso9660 ro,user,noauto          0       0

For example here the ext3 partition has been prepared for mandatory locking. Otherwise no dio_function will work on the system.
up
0
richard d_0t cubek a_t example D0_t com
7 years ago
IMPORTANT:

--enable-dio is NOT recognized as an option. After reporting a bug, i got following answer:

It is not bundled anymore. See http://pecl.php.net/dio to fetch the CVS version (being unmaintained, there is no release in pecl). Not a bug > bogus.
To Top