Pré-requis

Si vous disposez de la bibliothèque GD (disponible à » http://www.libgd.org/) vous pourrez aussi créer et manipuler des images.

Les formats des images que vous pourrez manipuler dépendent de la version de GD que vous installerez, et de toutes autres bibliothèques dont GD a besoin pour traiter ces images. Le support du GIF a été ajouté à partir de la version 2.0.28.

Note: Depuis PHP 5.0, libgd-2.0.4 ou supérieur est requis. Depuis PHP 5.5, libgd-2.1.0 ou supérieur est requis. Alternativement, utilisez la bibliothèque GD fourni avec PHP.

Vous pouvez aussi améliorer GD en lui ajoutant des formats d'images supplémentaires.

Formats d'images supportés
Format d'image Bibliothèque à télécharger Notes
gif   Uniquement supporté en versions de GD supérieures ou égales à la version 2.0.28. L'écriture est supportée depuis PHP 5.0.1.
jpeg » http://www.ijg.org/ Lors de la compilation de la bibliothèque jpeg (avant celle de PHP), vous devez utiliser l'option de configuration --enable-shared . Dans le cas contraire, vous recevrez une erreur disant que libjpeg.(a|so) not found lorsque vous tenterez de configurer PHP avant de le compiler.
png » http://www.libpng.org/pub/png/libpng.html
xpm » ftp://metalab.unc.edu/pub/Linux/libs/X/!INDEX.html Il est probable que vous ayez déjà cette bibliothèque disponible si votre système dispose d'un environnement X.

Vous pouvez aussi améliorer GD en lui ajoutant des fonctionnalités de manipulation de polices. Les bibliothèques suivantes sont supportées :

Bibliothèques de polices supportées
Bibliothèque de police Téléchargement Notes
FreeType 1.x » http://www.freetype.org/ La prise en charge de FreeType 1.x a été supprimé depuis PHP 5.3.0.
FreeType 2 » http://www.freetype.org/  
T1lib » ftp://sunsite.unc.edu/pub/Linux/libs/graphics/) Support pour les police Postscript Type 1 (supprimé depuis PHP 7.0.0).

add a note add a note

User Contributed Notes

There are no user contributed notes for this page.
To Top