PHP 5.5.17 is available

Introduction

Ceci est une extension pour planifier efficacement les I/O, les temps et les signaux basés sur les événements en utilisant le meilleur mécanisme I/O disponible sur une plateforme spécifique. C'est un portage de libevent pour l'infrastructure PHP.

Note:

Notez que le support Windows a été introduit en event-1.9.0.

La version 1.0.0 introduit une nouvelle API orientée objet (cassant ainsi la compatibilité ascendante), et ainsi que le support de libevent 2+, incluant les écoutes HTTP, DNS, OpenSSL et des événements.

Note:

Notez que event-1.0.0 et supérieur n'est pas compatible avec les versions précédentes.

add a note add a note

User Contributed Notes 1 note

up
0
AoK
4 months ago
PHP event service works at PHP 5.4+.  Couldn't get event to work on a PHP 5.3.10 install.

To get event working (OS X as an example):
1. brew install libevent
2. sudo pecl install event

This is tricky because pecl yields both "event" and "libevent" packages.  I was successful with "event" and not "libevent".
To Top