PHP 5.4.31 Released

Pré-requis

Les bibliothèques » OpenSSL et » libssh2 sont nécessaires. Assurez-vous que les bibliothèques de développement sont installées ; typiquement, le nom du paquet est openssl-dev.

La version 1.2 ou supérieure de la bibliothèque libssh2 est requise, mais il est possible que les nouvelles versions de pecl/ssh2 puissent nécessiter des versions encore plus récentes (voir les notes de versions).

La fonction ssh2_auth_agent() ne sera disponible qu'avec libssh >= 1.2.3.

Le support de la fonction stream_set_timeout() pour les flux d'un canal ne sera disponible qu'avec libssh >= 1.2.9.

Libssh2 peut contenir deux versions : gcrypt ou openssl. Quelques distributions Linux compilent libssh2 avec la bibliothèque gcrypt, alors que d'autres utilisent openssl. Libssh2 comporte quelques bogues lorsqu'elle est compilée avec gcrypt, aussi, il est conseillé d'utiliser openssl.

add a note add a note

User Contributed Notes

There are no user contributed notes for this page.
To Top