PHP Unconference Europe 2015

Dependências

Para usar xattr, você precisará ter a biblioteca libattr instalada no seu sistema. Ela está disponível em » http://oss.sgi.com/projects/xfs/.

Nota:

Essas funções só funcionarão em sistemas de arquivos que suportam atributos extendidos, e os quais tenham esses atributos habilitados no momento da montagem. Alguns sistemas de arquivos que suportam atributos extendidos são ext2, ext3, reiserfs, jfs, e xfs.

add a note add a note

User Contributed Notes 1 note

up
0
sven _ oostenbrink atserver yahoo dot co
5 years ago
An important thing to realize, if you wish to use xattr, you need a filesystem that has extended attributes functionalty and also has those enabled! I lost quite a bit of time with puzzling why xattr was not working with my ext4 system, until I found that the extended attributes, by default, are not enabled.

Adding user_xattr to the mounting configuration of the filesystem where I was working fixed the problem

/dev/sdb2    /home               ext4    relatime,user_xattr        0       2
To Top