其他变更

移动 utf8_encode()utf8_decode()

utf8_encode()utf8_decode() 现在已经作为字符串处理函数移到标准扩展中, 在此之前需要启用 XML 扩展才能使用。

支持 LMDB

DBA 扩展现在已经支持 LMDB。

PHP 构建系统的变更

  • Unix: 构建 PHP 需要 Autoconf 2.64 或更高的版本。
  • Unix: --with-pdo-oci 配置选项不再需要指定 Oracle Instant Client 的版本号数字。
  • Unix: 移除了 --enable-gd-native-ttf 配置参数。自 PHP 5.5.0 以来就已经不再使用。
  • Windows: 添加了 --with-config-profile 配置参数。 可用于保存细节配置,就像是神奇的 config.nice.bat 文件。

GD的变更

  • 当编译时使用了系统的 libgd,imageantialias() 也能生效。
  • imagegd() 以真彩色储存真彩色图像。在此之前,会转化为调色板图像。

移动 MCrypt 到 PECL

MCrypt 扩展从内核移动到 PECL。 考虑到 mcrypt 库自 2007 年以来未见任何更新,不再建议使用。 代替品即可以用 OpenSSL 也可以用Sodium

add a note add a note

User Contributed Notes

There are no user contributed notes for this page.
To Top