ScotlandPHP 2016

Instalação

PHP 4

Nota:

O suporte a Zip antes do PHP 4.1.0 é experimental.

Aviso

Por causa da extensão zip no PHP 4 zip não ser mantida nós recomendamos que a extensão PECL seja usada.

Sistemas Linux

Para usar estas funções você precisa compilar o PHP com suporte a zip usando a opção de configuração --with-zip[=DIR] , onde [DIR] é o prefixo da biblioteca instalada » ZZIPlib.

Windows

Usuários Windows precisam habilitar php_zip.dll no php.ini para usar estas funções.

PHP 5.2.0 e superior

Sistemas Linux

Para usar estas funções você precisa compilar o PHP com suporte a zip usando a opção de configuração --enable-zip .

Windows

Usuários Windows precisam habilitar php_zip.dll no php.ini para usar estas funções.

Instalação via PECL

Informações para instalar essa extensão PECL pode ser encontrada no capítulo Instalação de Extensões PECL. Informações adicionais como novas versões, downloads, arquivos fontes, manutenções e CHANGELOG podem ser encontrados aqui: » http://pecl.php.net/package/zip.

Uma DLL para esse extensão PECL não está disponível. Veja compilando no Windows section.

add a note add a note

User Contributed Notes 3 notes

up
-13
phpdev at ehrhardt dot nl
3 years ago
+1 for Tom's comment. I just requested to remove php_zip.dll from the example php.ini's:
https://github.com/php/php-src/pull/404

Please update the documentation as well.
up
-15
alvaro at demogracia dot com
5 years ago
Docs only mention PHP/4 and PHP/5.2.0 and later. For PHP/5.0 and PHP/5.1 you can simply install the PECL extension; despite being an external download, it's basically the same library.
up
-24
tom at tomwardrop dot com
7 years ago
To expand on the previous comment. This extension now seems to be built-in to PHP 5.3.0 (at least for windows).
To Top